Last week has been a really bad week for problems on my car. Started last Monday after the damn thing broke down while out to lunch. Despite having a full tank of gas, I couldnt get it to start. A similar problem happened the Thursday before when I thought I had ran the car out of gas; And after filling it with a Jerry can it was able to start again, but I was still quite sure it wasn’t empty. Anyways, I couldn’t do much in terms of repairs, so had to have it towed back to the house.

Turns out the Fuel Pump/Sending Unit is the culprit. After removing the cover to mine, I could see that it was extremely rusted, so rusted in fact that it didn’t take very much effort to break off the old locking ring instead of unscrewing it. Inside, the whole thing was heavily corroded and it wasn’t any wonder as to why it didn’t work anymore! Junkyard Time! Went to EZ Pull & Save junk yard and pulled another pump for $15 and spent all day Sunday installing it.

Unfortunately, the install didn’t go as smoothly as I would have liked. Due to the excessive rust on the old systems, the new lock rings would not correctly seal, and so when I would test drive the gar it would pour gas out of of the top of the new seal! After several attempts and cleanings, I have it sealed well enough that it now only leaks just a little amount of gas when the tank is very full and swishing about. Will re-seat it another day when I have time and energy to do so 🙂 If it continues to leak ever so slightly, I may need to replace the fuel tank =/

Share